Getting started

Followed the quickstart
managed to get “npm run codeceptjs:demo” working but “npm run codeceptjs:demo:headless” gives ‘HEADLESS’ is not recognized as an internal or external command,
operable program or batch file.
“npm run codeceptjs:demo:ui” gives :warning:You have to build Vue application by npm run build but there is no build script.

Was quite excited but the whole concept but if the documentation isn’t up to scratch it leaves me wondering what else is in store. Hoping there is a quick solution to this before I spend anymore time on this.

@nieperdragon I guess you’re trying with windows right? I tried with MacOS and worked perfectly.

tth~$ npm run codeceptjs:demo:headless

> codeceptjs-tests@0.1.0 codeceptjs:demo:headless
> HEADLESS=true codeceptjs run --steps -c node_modules/@codeceptjs/examples

CodeceptJS v3.4.1 #StandWithUkraine
Using test root "/Users/trung-thanh/Desktop/codeceptjs-playground/node_modules/@codeceptjs/examples"

Create Todos with BDD --
  Create a single todo item @bdd
    Given I have an empty todo list 
    When I create a todo 1 
    Then I see the new todo on my list 
  ✔ OK in 888ms


Regarding this, I believe this is an issue which shall be resolved by this fix(build): no dist folder is pushed to npm by kobenguyent · Pull Request #231 · codeceptjs/ui · GitHub

Yes tried on Win10 and Win11.
Never thought to try it on the Mac. I’ll give that a go, thanks.

Thanks again. I’ll give Windows another go once PR #has been merged.