Mochawesome reporter


#1

We have an issue we’re hoping to resolve quickly. Hopefully some of you can help!
We’re running codeceptjs and hoping to generate HTML reports to show the results of our test runs.

When we configure mochawesome and codeceptjs as shown on https://github.com/Codeception/CodeceptJS/blob/master/docs/reports.md#multi-reports, we get a strange result where codeceptjs run --reporter mochawesome runs zero tests and generates HTML to show this. Changing the run line back to --steps runs our tests as expected.

It seems like something in the execution breaks between mocha and mochawesome. We really like the format of the simple HTML reports and would love to include this (working!) in our project. Any ideas for us to try? Again, we followed the reports.md page to the letter, and for what it’s worth, we tried the Allure option as well, with the same result.


#2

@electric could you please send/let us the know the versions you are using ?


#3

Interestingly, my teammate found a way to make this work. Something in the AfterAll() section was preventing mocha from running. Replacing that with AfterSuite() and doing our previous call to a cleanup function made everything work correctly.


#4

Great thanks. Glad it’s all working now.